FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 20874|Reply: 14

FAQ regarding recovering from system errors in the X series players

Website Editor

Rank: 8Rank: 8

digest
2
posts
865
F-Coin
4734
Audio Sources
X1
AMPs
E12
regtime
2013-5-10
Post time 2015-3-26 09:57:36 |Show all posts |
Edited by FiiO-Shadow at 2015-6-18 14:51

Q: FAQ regarding recovering from system errors in the course of using an X series player or upgrading its firmware

A: In the unlikely case that your X5 2nd gen/X3 2nd gen/X1/X3/X5 produces a system error or frozen screen such that e.g. it cannot be shut down or turned on, please try to hard reset it first, simply by poking the reset hole with an unfolded paper clip;
If you run into a “system error” or something similar while updating the firmware, please perform a reset or forced shutdown (holding the power button on the X3 / X3 2nd gen / X5 for 15 seconds or holding the power buttong on the X5 2nd gen for 6 seconds or poking the reset hole in the X1 for 6 seconds) and attempt the upgrade again.  If the upgrade still fails, please try copying the firmware to a smaller capacity micro SD card (32GB or under) formatted in FAT32 (e.g. using the player) and attempt the update again.

Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
2
F-Coin
6
Audio Sources
X1 / X3SG
AMPs
X3SG / Yamaha R-N301
regtime
2015-2-18
Post time 2015-5-1 07:21:53 |Show all posts |
Hi,

I just upgraded to firmware version 1.3 for the X1. Upgrade was successful but when I try to manually update media library, it freezes every time with a message:

Media Lib updating...No.43

I presume there is some issue with track 43, though I have no idea how to identify this.

Any ideas please? Or will the new firmware function perfectly well without updating the libraray?

Thanks
Reply

Use magic Report

Senior Member

Rank: 4

digest
0
posts
34
F-Coin
491
Audio Sources
Fiio X1
AMPs
none
regtime
2015-1-15
Post time 2015-5-1 16:40:20 |Show all posts |
Edited by reelgirly at 2015-5-1 09:43

you could try to check the files on your player with "mp3 diags" for common errors...
perhaps this solves your issue...

https://sourceforge.net/projects/mp3diags/

really nice prog, also to correct vbr mp3 files in use with some other players

or u take out files step by step to determine which one causing ur freeze...
and also check ur SDcard by chkdsk or fsck

ey its me...
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
13
Audio Sources
X1
AMPs
Onkyo
regtime
2015-2-10
Post time 2015-6-4 03:38:27 |Show all posts |
After updating to FW1.3 the actualizing of my collection hangs somewhere at 450 tracks. I have to reset the X1 and start all over again. Always the same problem. After downgrading to FW1.1 everything works again. I have only hi-res ALAC-files on my player. No playlists. And no error...

So I'm waiting for something like FW1.3.1.....

Greetings from Germany
Rainer
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
2
F-Coin
6
Audio Sources
Fiio X1
AMPs
none
Head Gears
iGrado
regtime
2015-6-17
Post time 2015-6-18 20:38:31 |Show all posts |
Edited by chaocrator at 2015-6-18 21:59

i had the same issue with hangs on updating media library on my X1 with 1.3 & 1.4 firmware (currently using 1.4).
but when i changed media library update mode from Manual to Auto, everything seems to be working OK.
media library appears to be up to date.
update: no, it stopped working again.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
4
F-Coin
163
Audio Sources
X5ii, X1ii
AMPs
x
regtime
2015-6-23
Post time 2015-6-27 02:16:52 |Show all posts |
What's the equivalent to poking the reset hole for the x5ii (which doesn't seem to have a hardware reset button)?
Thanks
art
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
1
F-Coin
103
Audio Sources
Fiio X5
AMPs
Fiio E6, E07k, E09k
DACs
Fiio E07k
regtime
2016-6-21
Post time 2016-6-21 02:16:22 |Show all posts |
Hi, i just purchased the fiio x5(1st gen) from a seller on amazon and had it for a few days. It worked fine and sounded great, but 2 days ago when i tried to charge it, it did not want to charge. I used the cable that came with the x5 to charge and it didnt work, so i used my phone charger to make sure the x5 cable wasnt defective and it didnt charge still, so i plugged the x5 into my computer to upgrade the firmware to 2.7 to see if that might fix the issue, but when i plugged the x5 into the computer it keeps saying "usb device malfunctioned", so i had no way to view the x5 files or update it whatsoever from my computer. i also tried holding the power button for 15 seconds and pressing the reset button and still have this problem. Currently my x5 is dead and i dont know what to do, can you help me?
Reply

Use magic Report

Technical Support

Rank: 5Rank: 5

digest
0
posts
1896
F-Coin
6593
Audio Sources
X5
AMPs
E18
regtime
2014-11-18

Senator if Forums Honorary Admin Excellent Moderator Master of Publictity Enthusiastic Member Active Member Supernova

Post time 2016-6-21 16:47:39 |Show all posts |
KawhiLeonard23 replied at 2016-6-21 02:16
Hi, i just purchased the fiio x5(1st gen) from a seller on amazon and had it for a few days. It work ...

Hi, KawhiLeonard, can you see the led right on the bottom of x5 when you connect it to the charger or the PC? And can you turn it on while connect it to your charger or pc?
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
13
F-Coin
41
Audio Sources
Fiio X1
AMPs
None
Head Gears
Yamaha EPH-100SL
regtime
2015-7-29
Post time 2016-6-21 17:35:00 |Show all posts |
Edited by team-muz at 2016-6-21 17:42

Hi I am stuck in a system error "loop" on my X1. I had sccesfully updaetd to 2.0 and then I foolishly created and copied a custom x1 theme into the 2.0 fw without thinking and now power button or hard reset have not worked and I seem to have crashed my 128GB 'genuine' SanDisk SD as that is not being read by my PC. I can power up but keep receiving a red "system error" message. I get a blue LED and cannot completely power off either. Stupid me has just ruined the second love of my life which has performed flawlessly to this stage. Any suggestions appreciated.
Reply

Use magic Report

Technical Support

Rank: 5Rank: 5

digest
0
posts
1896
F-Coin
6593
Audio Sources
X5
AMPs
E18
regtime
2014-11-18

Senator if Forums Honorary Admin Excellent Moderator Master of Publictity Enthusiastic Member Active Member Supernova

Post time 2016-6-22 11:42:58 |Show all posts |
team-muz replied at 2016-6-21 17:35
Hi I am stuck in a system error "loop" on my X1. I had sccesfully updaetd to 2.0 and then I foolishl ...

Hi, pls refresh the firmware 2.0 to test.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
13
F-Coin
41
Audio Sources
Fiio X1
AMPs
None
Head Gears
Yamaha EPH-100SL
regtime
2015-7-29
Post time 2016-6-29 19:12:26 |Show all posts |
Edited by team-muz at 2016-6-29 19:13

Sorry for taking so long to reply...I've been listening to my X1 I was able to restart and flash back to 1.6 and successfully upgrade back up to 2.0. Everything is fine love the updates and my SD card was saved too.  
Should 1.6 themes be compatible with 2.0 given the menu changes etc?
Reply

Use magic Report

Technical Support

Rank: 5Rank: 5

digest
0
posts
1896
F-Coin
6593
Audio Sources
X5
AMPs
E18
regtime
2014-11-18

Senator if Forums Honorary Admin Excellent Moderator Master of Publictity Enthusiastic Member Active Member Supernova

Post time 2016-6-30 19:14:41 |Show all posts |
team-muz replied at 2016-6-29 19:12
Sorry for taking so long to reply...I've been listening to my X1  I was able to restart and flash  ...

Hi, do you mean the themes you DIY? It is suggested to use the 2.0 version firmware to DIY the themes again. They may not be compatible well.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
13
F-Coin
41
Audio Sources
Fiio X1
AMPs
None
Head Gears
Yamaha EPH-100SL
regtime
2015-7-29
Post time 2016-7-8 05:29:25 |Show all posts |
Yellow replied at 2016-6-30 19:14
Hi, do you mean the themes you DIY? It is suggested to use the 2.0 version firmware to DIY the them ...

Yes DIY themes...it appears they may not be compatible given the FW2.0 updates and extra menu functions. I might ask some further questions in a "theme" thread. Thanks for your help.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
9
Audio Sources
yinyuan
AMPs
erfang
regtime
2016-9-20
Post time 2016-9-20 22:17:48 |Show all posts |
I bought my FiiO X5 1st Gen player in Feb-March 2015. Everything was fine. I did upgrade firmware etc. Few days ago player stopped playing. Just stopped and did shut off. I put it on charge. Charging screen did not appear. When I plugged charger (2.0A) green light switched to red. I waited few hour till its fully charged. Red light switched to solid green. But player still did not go on. It did not turn on at all. I tried soft reset. None. No response. I tried hard reset - 1st I pressed that hole once. and nothing happened. I waited 10 sec. Then I pressed on/off button. Nothing happened. Then I pressed hard reset hole and kept it pressed for 14 seconds. Nothing happened. I tried on/off button again and nothing happened again. When I connect player to PC, computer does not see the player. What should I do to make it work again???
Reply

Use magic Report

Customer Service

Rank: 5Rank: 5

digest
0
posts
370
F-Coin
928
Audio Sources
X3
AMPs
E17K
DACs
Q1
regtime
2016-7-12

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2016-9-21 16:55:21 |Show all posts |
GooDWiin_17 replied at 2016-9-20 22:17
I bought my FiiO X5 1st Gen player in Feb-March 2015. Everything was fine. I did upgrade firmware et ...

Hi, GooDWiin_17
It seems to be some problem with your X5. I am afraid it need repair.
Could you please send an email to support@fiio.net? Please attach the reciept/invoice as well. Thank you and sorry for bringing inconvenience.
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2019-3-21 07:54 , Processed in 0.035234 second(s), 22 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top