FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
Author: FiiO-Shadow

X1/X3/X5/X3II/X5II - theme DIY turorial

Senior Member

Rank: 4

digest
0
posts
35
F-Coin
501
Audio Sources
X1
AMPs
AMPs!
Head Gears
Bose SoundTrue™ & Sennheiser Momentum
regtime
2015-11-26
Post time 2016-7-30 22:08:50 |Show all posts |
Edited by Micha-San at 2016-7-30 22:13

Hello Red_Bull,

in post 1# of this thread are shown the essentials. Please read carefully - it's not such difficult.

You have to unpack both firmware files - ELIX1R FW1.6 and FiiO FW2.0 - in seperate folders of your computer. In both cases use the program that is linked to in post 1#.

The folder "litegui" contain all graphics used for the GUI - refer to picture 5 of post 1#. You may use a picture viewer of your choice to browse through the folders to locate the theme you like.

Now copy the desired theme(s) from the source (ELIX1R) to the target (FiiO) and re-pack the FW.

Update you FiiO and that's all.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
17
F-Coin
66
Audio Sources
X1
AMPs
X1
regtime
2016-12-23
Post time 2016-12-23 23:27:46 |Show all posts |
Hello, I'm trying to make a new theme for my X1 and am having trouble with the Packtools app. Initially I tried using it on my Mac and it simply would always say it couldn't unpack the x1.fw. Then I tried it on my PC and it worked, and I started working on the new theme, but when I went over to pack it back up, I started having issues there, with Packtools crashing every time I clicked on pack. Somehow, I managed to get it to work, by unpacking a x1.fw, then simply pasting all the subfolders of my personalised theme into the resulting folder, leaving the x1.fw also there and then clicking on pack. It worked once but now it no longer works. And I have a theme I've spent hours making and it seems I won't be able to pack it back up to use it! Nor can I find any reference to anyone having this issue. It's simply that when I click on pack.bat, a cmd window opens but, at the same time, a window pops up saying "packtools.exe has stopped working". Any help, please?!
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
7
F-Coin
87
Audio Sources
Fiio X1 2nd Gen, Sony Walkman
AMPs
JBL AVR134
regtime
2017-6-7
Post time 2017-6-21 18:16:47 |Show all posts |
Is there any update in this toolset to be used for X1 2nd Gen firmware?
Reply

Use magic Report

Senior Member

Rank: 4

digest
0
posts
121
F-Coin
511
Audio Sources
FiiO X3 II
AMPs
Sony
DACs
FiiO X3 II
Head Gears
FiiO EX 1
regtime
2015-8-30
Post time 2017-7-13 07:19:38 |Show all posts |
vinaysharma76 replied at 2017-6-21 11:16
Is there any update in this toolset to be used for X1 2nd Gen firmware?

kudos!

I would like to make an Italian translation of the interface
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2020-4-9 22:48 , Processed in 0.020728 second(s), 21 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top